Government Advising Against Using Internet Explorer

Following on from the news that virtually every edition of Internet Explorer has been affected by a new serious security flaw, the Department of Homeland Security is advising everyone against using Internet Explorer until the security threat has been resolved.

The New York Times reports:

The United States Computer Emergence Readiness Team said in an advisory released on Monday morning that the vulnerability in versions 6 to 11 of Internet Explorer “could lead to the complete compromise of an affected system.”

The vulnerability, which was detected over the weekend means that hackers could make light work of Internet Explorer and gain access to any information if they simply had the know-how.

Make sure to keep an eye out for updates on this issue, and for now we strongly advise using an alternative browser until these problems are resolved.